Sunday, 2 October 2011

Broken Beko washing machine spins really fast

I know this is a tedious blog about fixing my computer problems, but since I feel duty bound to give information back to the interwebs after it's helped me, I hope a post about washing machine fixes will be acceptable.

So, here's hoping this post will turn up for people google-ing for the same problems as me this morning.

My Beko WMA520W washing machine broke last night. Half way through a wash there was a "wheeee!" noise and the drum stopped. We turned it off and took the laundry out. Thereafter, every time I turned it on, it pumped water out, then spun really fast, then stopped. Even turning it off at the wall or holding down the cancel button would not re-set it, as it was convinced it was mid-cycle.

I bring you a two-part solution. First, according to this post, there is a magic raindance on the front control panel to re-set the machine:

  • Turn the power button off but leave the machine on at the wall
  • Select a 90 degree wash
  • Hold the start/cancel button down for 3 seconds and turn the power button on whilst still holding buttons down. The start light will flash.
  • Select any spin position.
  • Hold down the start/cancel button again for 3 seconds. If other buttons start to flash, press start/cancel again for 3 seconds.
Now the machine is happy to accept instruction. We tried a nice rinse cycle, with the machine empty. It filled with water okay, but when it got to tumble-time, the drum just span up to warp speed again, then stopped.

After checking various things, we removed the motor and the issue turned out to be a shattered tachometer magnet. The magnet pieces no longer rotated with the motor shaft, so there was no induced current in the tacho coil. The control unit therefore assumed the motor was not rotating, so increased the speed until it reached some safety cut-off.

In this model, the magnet appears to have been formed around a textured brass ring, so even if spares were available (and the internet doesn't seem to have any) it seems unlikely you could get a replacement on without shattering it. We opted for some Araldite Rapid Steel epoxy and have tried to glue the two pieces back together. This may not last us very long, and we don't intend to leave the washer on when we're not around, just in case! It we want a longer-term fix, it seems the only option is to buy a whole new motor which seems a bit stupid just for a magnet, but hey ho. We'll try the £5 fix over the £80 one any day. Of course, the third option is to obtain the new motor less expensively by cannibalising other Beko machines at the skip or otherwise obtaining a broken one for spares.

Other news from my fascinating journey round the Beko's guts:

We've always had to pour another 20 litres of water through the tray on a wash cycle as the machine doesn't put anywhere near enough water in. However, it looks like we can make adjustments on the fill pressure sensor (top front right corner) in the future, but let's break one thing at a time for now.

Some corners of the web mention timing wheels and other such nonsense. I didn't see any of those inside our beastie, so I conclude most of the control goes on inside the processor (an Atmega32). When that gets toasted, it'll be £50 for a new board :-(

3 comments:

Killroy555 said...

Anyone out there found a company who can supply me with the tacho magnet ?

Gunnar

mrizzard said...

No not me, i'm looking for exactly the same thing.

Killroy, did you find one in the end?

Many thanks

Ali said...

From what I saw, you'd have trouble getting a replacement onto the shaft - it looks like it's been formed around the shaft itself, as the inside of my shattered magnet contained an impression of the shaft texture. If your magnet is not completely pulverized, I'd recommend metal epoxy, possibly with some wire wound around for strength (if there is clearance inside the tacho coil). Our machine ran for another 6 months with this, and would probably still run, if it were not sitting sad and lonely in the garage of our new house which came with another machine in it already...